GDB e sublime text

#1
Buonasera a tutti,
è da questo pomeriggio che sto tentando di impostare sublimeGDB e sto iniziando a sclerare.
Ho creato il file Json e ho scritto questo codice
Codice:
{
    "folders":
    [
        {
            "path": "C:\\Users\\User\\Documents\\C\\esercizio1"
        }
    ],
    "settings":
    {
          "sublimegdb_workingdir": "C:\\Users\\User\\Documents\\C\\esercizio1",
          // NOTE: You MUST provide --interpreter=mi for the plugin to work
          "sublimegdb_commandline": "gdb --interpreter=mi main.exe"
   
     }
}
Tuttavia mi da errore

Anche se provo a scrivere quest'altro codice mi da errore
Codice:
{
    "folders":
    [
        {
            "path": "C:\\Users\\User\\Documents\\C\\esercizio1"
        }
    ],
    "settings":
    {
          "sublimegdb_workingdir": "${folder:${project_path:main.exe}}",
          "sublimegdb_commandline": "gdb --interpreter=mi main.exe"
   
     }
}
Qualcuno sa quale possa essere il problema?
Utilizzo tdm-gcc come compilatore e lavoro su windows 10.
Inoltre qualcuno potrebbe spiegarmi come impostare sublime in modo da farlo compilare in -g?
 
570
197
Hardware Utente
CPU
i5 6600k
Dissipatore
AIO H100
Scheda Madre
ASUS z170 Deluxe
Hard Disk
1 WD Blue 1 TB; evo 850 500gb
RAM
Vengeance 4x4
Scheda Video
GTX 1080 Asus
Scheda Audio
Nope
Monitor
Dell UP3216Q
Sistema Operativo
PucyBuntu
#2
Buonasera a tutti,
è da questo pomeriggio che sto tentando di impostare sublimeGDB e sto iniziando a sclerare.
Ho creato il file Json e ho scritto questo codice
Codice:
{
    "folders":
    [
        {
            "path": "C:\\Users\\User\\Documents\\C\\esercizio1"
        }
    ],
    "settings":
    {
          "sublimegdb_workingdir": "C:\\Users\\User\\Documents\\C\\esercizio1",
          // NOTE: You MUST provide --interpreter=mi for the plugin to work
          "sublimegdb_commandline": "gdb --interpreter=mi main.exe"
  
     }
}
Tuttavia mi da errore

Anche se provo a scrivere quest'altro codice mi da errore
Codice:
{
    "folders":
    [
        {
            "path": "C:\\Users\\User\\Documents\\C\\esercizio1"
        }
    ],
    "settings":
    {
          "sublimegdb_workingdir": "${folder:${project_path:main.exe}}",
          "sublimegdb_commandline": "gdb --interpreter=mi main.exe"
  
     }
}
Qualcuno sa quale possa essere il problema?
Utilizzo tdm-gcc come compilatore e lavoro su windows 10.
Inoltre qualcuno potrebbe spiegarmi come impostare sublime in modo da farlo compilare in -g?
Perchè mai dovresti debuggare con sublime text quando puoi farlo direttamente da terminale? se è ostica come cosa vai di eclipse ha un debugging migliore, sublime è un editor non ide.